I cannot access my dorm with my ID card, what should I do?

Dorm Access Issues

I cannot get into my dorm with my ID card. Neither my physical ID card or my digital ID card on my phone will let me in. I scan the card, and the scanner blinks red and beeps, but the door doesn't unlock or open.

Applies to: 

  • Students

Causes:

  • Lack or Student Health Center clearance
  • Lack of an active/assigned door access plan

Resolution

  1. First, ensure that you have completed all Health Requirement Tasks in myaccount.biola.edu.
    1.  !  Note: New dorm/campus access is automatically applied at 6:30am on the next business day after the Health Requirement Tasks are completed.
  2. Next, contact the Biola Housing Office: (562) 944-0351, ext: 5838, or undergrad.housing@biola.edu to make sure that you have the right door access plan assigned, and that the plan is active.

 


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Details

Article ID: 14460
Created
Tue 8/20/24 1:35 PM
Modified
Tue 8/20/24 2:02 PM