#Q: I cannot access my dorm with my ID card, what should I do?
Summary
I cannot access my dorm with my ID card, what should I do?
Body
Dorm Access Issues
I cannot get into my dorm with my ID card. Neither my physical ID card or my digital ID card on my phone will let me in. I scan the card, and the scanner blinks red and beeps, but the door doesn't unlock or open.
Immediate Next Steps
If you need immediate access to your dorm, call the Biola Campus Operator: (562) 903-6000 and request that Campus Safety come and open the door for you. If you feel unsafe, call 911 or Biola Campus Safety Emergency line: (562) 777-4000 (or x5111 from campus phone).
Applies to:
Cause:
- Lack of an active/assigned door access plan
Resolution
- Contact the Biola Housing Office: (562) 944-0351, ext: 5838, or undergrad.housing@biola.edu to make sure that you have the right door access plan assigned, and that the plan is active.
If something else is wrong...
If you can get into your dorm but cannot get into a non-residential building, (such as Sutherland Hall, the Lim building, the Business building, or any other building where classes take place) then you will want to contact Campus Safety at campus.safety@biola.edu.
If your ID card is not working at all (e.g.: when you try to scan at any card reader nothing lights up or beeps) then visit IT Services at the Tech Commons desk in the Library during normal business hours for troubleshooting.
Need more help?
If you cannot find your answer here or related articles, please view the section "Related Services / Offerings" to open a ticket.
Please provide feedback on this article, especially if it is not accurate or providing an answer you expect. Select "Yes" or "No" below where is asks "Was this helpful?" This feedback helps us and the rest of the community provide better resources.
Details
Details
Article ID:
14460
Created
Tue 8/20/24 4:35 PM
Modified
Mon 3/9/26 3:48 PM